Debian.cn
Debian中文资讯站

如何在 Debian Stretch 中安装使用 PHP5

在 Debian Stretch 中,系统自带的 PHP 版本已经默认为 PHP 7.0。我们如何在 Debian 9 中,把 PHP 的版本降为 Php 5 呢?本文提供了一种多个 PHP 版本共存的方案,我们以安装配置 PHP-5.6 为例,并且支持在多个 PHP 的版本中切换。

首选,我们需要配置一个新的安装源,以便安装 php 5.6 的包,这里我们选择 deb.sury.org ,

打开终端,运行以下命令,

apt-get install apt-transport-https lsb-release ca-certificates

然后下载安装对应的GPG key 文件,使用命令,

wget -O /etc/apt/trusted.gpg.d/php.gpg https://packages.sury.org/php/apt.gpg

或者这个命令,

curl https://packages.sury.org/php/apt.gpg | apt-key add -

随后,我们就可以把安装源配置起来了。执行以下命令即可:

echo "deb https://packages.sury.org/php/ $(lsb_release -sc) main" > /etc/apt/sources.list.d/php5.list

现在我们就可以开始安装 php 5.6 了,

apt-get update
apt-get install php5.6 php5.6-mysql php5.6-xml php5.6-zip php5.6-json php5.6-gd php5.6-bcmath

现在我们有了 php 5.6 和 php 7.0 两个版本,我们如何在两个版本之间切换呢?使用以下命令即可,

update-alternatives --config php

输出样例如下:

 

----------------------------------------------------------
* 0            /usr/bin/php7.0   70        mode automatique
  1            /usr/bin/php5.6   56        mode manuel
  2            /usr/bin/php7.0   70        mode manuel

至此,你就在 Debian Stretch 上有了一个 PHP 5.6 的环境。


分享到:
赞(0)
未经允许不得转载:Debian中文 » 如何在 Debian Stretch 中安装使用 PHP5
已有 0 条评论