1

我用nodejs的npm安装web-ext时总是失败,请帮忙看一下是怎么回事。谢谢!!
安装命令:npm install –global web-ext
提示如下:
npm WARN deprecated js-select@0.6.0: Package no longer supported. Contact support@npmjs.com for more info.
npm WARN deprecated markdown-to-ast@3.4.0: See https://github.com/textlint/textlint/issues/455
npm WARN deprecated nomnom@1.8.1: Package no longer supported. Contact support@npmjs.com for more info.
npm WARN deprecated socks@1.1.10: If using 2.x branch, please upgrade to at least 2.1.6 to avoid a serious bug with socket data flow and an import issue introduced in 2.1.0
/home/ssew/node-v8.11.2-linux-x64/bin/web-ext -> /home/ssew/node-v8.11.2-linux-x64/lib/node_modules/web-ext/bin/web-ext
npm WARN ajv-keywords@2.1.1 requires a peer of ajv@^5.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules/web-ext/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {“os”:”darwin”,”arch”:”any”} (current: {“os”:”linux”,”arch”:”x64″})

  • web-ext@2.7.0 updated 1 package in 96.971s

系统是debian9.1 (stretch),nodejs是8.11.2LTS版。
nodejs我是下载到home目录后把node和npm软连接到/usr/local/bin的。
web-ext我是用于做Firefox扩展用的。


分享到:
问的提问